Laboratory Manual

MULTIMEDIA SYSTEMS

For

MCA Students


Author JNEC, Aurangabad
FORWARD

It is my great pleasure to present this laboratory manual for Final year MCA students for the subject of Multimedia Systems keeping in view the coverage required for the concepts of Multimedia related to Web design and advertisements on web using Photoshop, Corel draw, Movie Maker and sound editing tools etc.

As a student, many of you may be wondering with some of the questions in your mind regarding the subject and exactly what has been tried is to answer through this manual.

As you may be aware that MGM has already been awarded with ISO 9001-2000 certification and it is our endure to technically equip our students taking the advantage of the procedural aspects of ISO 9001-2000 Certification.

Faculty members are also advised that covering these aspects in initial stage itself, will greatly relived them in future as much of the load will be taken care by the enthusiasm energies of the students once they are conceptually clear.

Dr. Sudhir Deshmukh
Principal
LABORATORY MANUAL CONTENTS

This manual is intended for the Final year students of MCA branch in the subject of Multimedia System. This manual typically contains practical/Lab Sessions related Multimedia System covering various aspects related the subject to enhanced understanding.

Although, as per the syllabus, We have made the efforts to cover various aspects of Multimedia Systems.

Students are advised to thoroughly go through this manual rather than only topics mentioned in the syllabus as practical aspects are the key to understanding and conceptual visualization of theoretical aspects covered in the books.

Good Luck for your Enjoyable Laboratory Sessions

S. R. Kondekar
MCA Department
**DO’s and Don’ts in Laboratory:**

1. Do not handle any equipment before reading the instructions/Instruction manuals

2. Read carefully the power ratings of the equipment before it is switched on whether Ratings 230 V/50 Hz or 115V/60 Hz. For Indian equipments, the power ratings are normally 230V/50Hz. If you have equipment with 115/60 Hz ratings, do not insert Power plug, as our normal supply is 230V/50 Hz, which will damage the equipment.

3. Observe type of sockets of equipment power to avoid mechanical damage

4. Do not forcefully place connectors to avoid the damage

5. Strictly observe the instructions given by the teacher/Lab Instructor

**Instruction for Laboratory Teachers:**

1. Submission related to whatever lab work has been completed should be done during the next lab session. The immediate arrangements for printouts related to submission on the day of practical assignments.

2. Students should be taught for taking the printouts under the observation of lab teacher.

3. The promptness of submission should be encouraged by way of marking and evaluation patterns that will benefit the sincere students.
1. LAB EXERCISES:

[Purpose of these exercises to make familiar students with draw shapes, add color to objects, duplicate, rotate, mirror objects, import images from file, use smart drawing, ellipse, rectangle, interactive drop shadow, and text tools to CorelDraw Tools and Design a Logo for Company/Shop or Activity]

**Exercise No1: ( 2 Hours) - 1 Practical**

[Purpose of these exercises to make familiar students to CorelDraw Tools and Design a Logo for Coffee shop]

First create a new, blank document.

Then create triangles that form the shape of the background by using the Smart drawing tool. Then rotate, mirror, and move the triangles into position, and finally, create the decorative circles for the logo.

**To create triangles for the background**

1. Click File→ New.
2. In the toolbox, click the Zoom tool
3. From the Zoom levels list box on the standard toolbar, choose To width.
4. In the toolbox, click the Smart drawing tool
5. From the Shape recognition level list box on the property bar, choose Highest.
6. From the Smart smoothing level list box, choose Medium.
7. Choose 1.0 pt from the Outline width list box on the property bar.
8. In the Outline Pen dialog box, ensure the Graphic check box is enabled, and click OK.
9. Draw a triangle and a smaller triangle.
10. To keep the small triangle in the big one, in the toolbox, click the Pick tool
11. Click the smaller triangle and drag it to place it inside the larger triangle.
12. Click Edit→Select all Objects.
13 Clicks **Arrange** → **Group**. When objects are grouped, you can manipulate them as a single object.

**To arrange the triangles to create the background**

1 Click **View** → **Snap to objects**. Click the **Pick** tool and select the triangle group.

2 In the **Angle of rotation** box on the property bar, type **45** and press **Enter**.

3 Click **Edit** → **Duplicate** to create another triangle group.

4 In the **Duplicate offset** dialog box, type a value in the **Horizontal offset** and **vertical offset** boxes, and click **OK**.

5 Click the **Mirror horizontal** button on the property bar.

6 Drag the duplicate triangle group to the right of the first group. Make sure their corners are touching.

7 Click **Edit** → **Select all Objects**.

8 Click **Edit** → **Duplicate**. Click the **Mirror vertical** button on the property bar.

9 Drag the duplicate triangle groups below the first set. Make sure their corners are touching.

**To create decorative circles for the background**

1 In the toolbox, click the **Ellipse** tool. Drag to create an ellipse on a blank area of the drawing. If you want to draw a perfect circle, you can hold **Ctrl** to constrain the shape as you draw it.

2 Click the **Pick** tool and select the circle.

3 Drag the circle to the edge of one of the triangle groups. Place it between the top and the bottom of the triangle. Refer the image as given below to see where to place the circles.

4 Click **Edit** → **Duplicate**. Repeat this step until you have 5 additional circles. We need total of 6 circles. Drag the remaining circles to the edges of the triangle groups. Place each circle in between the top and bottom of the triangle. Following is the drawing look like:
Adding color

There are different color models you can use to choose colors from, such as grayscale, CMYK, or RGB. The CMYK color model is used for creating images you intend to print later, and it ensures high-quality color printing. The RGB model, on the other hand, is optimized for the screen. For this project, you will use the RGB color model.

To add color to outer triangles

1. Click **Edit → Select all Objects.**
2. Click **Arrange → Ungroup all.**
3. Click the **Pick** tool. Hold down **Shift,** and select the four outer triangles.
4. Open the Fill layout, and click the Fill color dialog button
5. Click the Models tab. From the Model list box, choose RGB.
6. In the **R** box, type **153,** in the **G** box, type **153,** in the **B** box, type **51** and click **OK.**

To add color to the inner triangles

1. Click the **Pick** tool. Hold down **Shift,** and select the four inner triangles.
2. Open the Fill layout, and click the Fill color dialog button
3. Click the Models tab. From the Model list box, choose RGB. In the **R** box, type **255,** in the **G** box, type **204,** in the **B** box, type **0.** Click **OK.**

To add color to the circles

1. Click the **Pick** tool. Hold down **Shift,** and select the six circles.
2. Open the Fill fly out, and click the Fill color dialog button
3. Click the Models tab. From the Model list box, choose RGB. In the **R** box, type **255,** in the **G** box, type **249,** in the **B** box, type **116.**
4. Clicks **OK.** This is what the drawing should look like:
Creating the diamond shape

To make the coffee cup stand out from the background, the logo uses a diamond shape overlying the background for the coffee cup. The diamond shape consists of two overlapping squares, one slightly smaller than the other, which are grouped and then rotated 90 degrees to form the diamond.

To create the outer square

1. Using the **Rectangle** tool, drag to create a square on a blank area of the drawing. The square should be smaller than the background, but big enough to cover the middle of the background. If you want an exact square, you can hold down **Ctrl** to constrain the shape as you draw it.

2. From the **Shape edit** fly out, click the **Shape** tool.

3. Drag a corner node to round the corner of the square.

To create the inner square

1. Click the **Pick** tool, and select the square.

2. Click **Edit → Copy** then **Paste** to place a duplicate of the square on top of the original square. The top most square completely covers the original square.

3. Click the **Pick** tool. Hold down **Shift** and drag one of the corner selection handles until the square is slightly smaller than the original square. By holding down **Shift**, you are resizing the square from its center.

To add color to the outer square

1. Select the larger square using the **Pick** tool.

2. On the color palette, click a **Red** color swatch.

3. In the **Outline width** box on the property bar, type **2.5** and press **Enter** to give the square a thicker outline.

To add color to the inner square

1. Select the smaller square using the **Pick** tool

2. Open the **Fill** fly out, and click the **Fill color dialog** button.

3. Click the **Models** tab. From the **Model** list box, choose **RGB**.

4. In the **R** box, type **229**, in the **G** box, type **255**, in the **B** box, type **229** and press **OK** to fill the square with the specified color.
In the **Outline width** box on the property bar, type **2.5** and press **Enter** to give the square a thicker outline.

**To rotate the squares to create diamonds**

1. Select the smaller square using the **Pick** tool
2. Hold down **Shift**, and click the larger square. Both squares are now selected.
3. Click **Arrange -> Group** to group the two squares.
4. In the **Angle of rotation** box on the property bar, type **45** and press **Enter**. This rotates the squares to create a diamond shape.
5. Drag the resulting diamond shape on top of the background. If the diamond shape is too large or too small, resize the diamond by dragging one of the corner selection handles.

**Adding the coffee cup and drop shadow**

Now that you have created the diamonds, you can add the coffee cup to the logo. The coffee cup already exists as a Corel DRAW (CDR) file. To add the coffee cup, you will import the coffee cup file.

To make the coffee cup stand out from the rest of the logo, you can add a drop shadow by using the **Interactive drop shadow** tool. The drop shadow gives the illusion that the coffee cup is floating above the rest of the logo, giving the image more depth.

**To import the coffee cup**

1. Click **File -> Import**.
2. From the **Files of type** list box, choose **CDR - CorelDRAW**.
3. Choose the folder **Program filesGraphics Suite 13 Sample files**.
4. Choose the filename **cup.cdr** and Import.
5. Position the pointer on a blank area of the drawing page, and click to place the coffee cup graphic.
6. Drag to center the coffee cup graphic on top of the diamond shape. Adjust the size of graphic by dragging one of the selection handles. In case if the figure is not available you can create your own by using any other tool and import it.
To add a drop shadow to the coffee cup

1. Open the Interactive tools fly out, and click the Interactive drop shadow tool.
2. Click the coffee cup graphic.
3. Drag from the center of the coffee cup graphic to the lower left until the drop shadow is the size you want. Zooming in can make it easier to set the size of the drop shadow.

2. Lab Exercises:

[Purpose of these exercises to make students familiar with Ellipse tool, interactive fountain fill tool of CorelDraw Tools and Design a Design 3D button for web page]

Exercise No2: (2 Hours) - 1 Practical

Design a 3D button for a Web Page.

In this tutorial you will learn how to create a 3 dimensional button that can be used when building a web page.

Drawing the Button
After creating a new document by selecting File New, and selecting Web from the Preset destination, click OK.

1. Creating an ellipse in CorelDRAW is very straightforward. From the Toolbo
x on the left side of the screen, select the Ellipse tool, it is the 8th tool from the top. Create an ellipse that is 40 pixels in diameter. You can verify the diameter by looking at the interactive property bar as you draw. Holding the Ctrl key down while you create the ellipse will constrain it to a perfect circle.

2. With the ellipse still selected, click on the Interactive Fill tool in the toolbox. This is the last tool. Drag diagonally
across the ellipse to apply a linear fountain fill. With the fountain fill control handles still selected, click on the red color swatch in the color palette.

3. Duplicate this ellipse and resize it to 33px; then on the Interactive property bar, set the Angle of rotation to 180 and press Enter. If the duplicated circle is offset from the first one then ensure both circles are selected and type “C” and then “E” to align them perfectly on center.

CorelDRAW allows you to export to the three common file formats used in Web design. Determining which format is best for a design that you may be working on greatly depends on the requirements for the file. Here is a brief explanation of each file type.

**What File Format Is Best**

**GIF**: GIF images are best used for line drawings, text, images with few colors, or images with sharp edges, such as scanned black and white images or logos. GIF offers several advanced graphic options, including setting a single color to be shown as transparent, interlaced images, and animation. It also lets you create custom palettes for the image.

**PNG**: PNG files are best for various image types, including photos and line drawings. The PNG file format (unlike the GIF and JPEG formats) supports the alpha channel or soft transparency. This allows you to save transparent images with soft edges and high quality.

**JPEG**: Photos and scanned images are best exported as JPEG files. JPEG files use file compression to store an approximation of an image, which results in some loss of image data, but does not compromise the quality of most photographs. You can choose the image quality when you save an image—the higher the image quality, the larger the file size.

For this type of image, it is recommended to use PNG.

**Export for Web**

The Export for Web dialog box provides a single access point for common export controls, eliminating the need to open additional dialog boxes when preparing a file for export. It also lets you compare the results of various filter settings before you commit to an output format, making it easier to achieve the best results.
3. Lab Exercises:
[Purpose of these exercises is to design 3D looking text that can be used for heading or slide presentation using CorelDraw]

Exercise No3: (2 Hours) - 1 Practicals
Create artistic text and apply a Drop Shadow and adjust the Settings.

Creating Artistic text
CorelDraw has two different types of text, artistic text and paragraph text. Artistic text is used for creating headings and titles while paragraph text is used for things like, well paragraphs. Let’s begin by creating the text.

1. From the Toolbox on the left side, select the Text tool and click on the page.
2. Type your text and change the font. For this effect to work well, it would be better to use a font that is quite thick, such as Arial Black or Cooper Black. Here we use Cooper Black and set the point size to 72 pt.

Adding the Drop Shadow
Adding a Drop Shadow is a simple matter of clicking and dragging using the Interactive Drop Shadow tool.

6. From the toolbox, click on the Interactive Tool Flyout (this is the 5th icon from the bottom) and hold the mouse button down. Select the Drop Shadow tool.
7. Left mouse click in the center of the text and drag outwards to create the shadow.

Next, we need to make some very specific adjustments to the shadow and these can be done in the Interactive property bar at the top of the screen. They are:
A. Set both the X and Y co-ordinates to 0:0.
B. Change the Drop shadow opacity to about 85 (This setting will vary depending on the point size of the text).
C. Change Shadow feathering to 12-15. (This setting will vary depending on the weight of the font).
D. Set Feathering direction to Inside
E. Set Transparency Operation to Normal
F. Change Shadow Color to White

The final stage is to bring the Drop Shadow to the front of the text. In order to do this, we first need to separate the shadow from the text.
A. Select Arrange  Break Drop Shadow Group Apart
B. Select Pick tool by tapping Spacebar (which toggles between pick tool and the last tool used) and deselect all objects by clicking on a blank area of the page.
C. Bring the drop shadow to the front by clicking in between the characters and then holding down the Ctrl key and tapping the Home key.

If you want to change the color of the text, simply hold the Alt key and click on the shadow. The Alt+Pick combination acts as a “digger” tool to select objects under other objects) then left click the color from the palette on the right of the screen.

4. **Lab Exercises:**

   [Purpose of these exercises is to design a movie on given topic by using photos, videos, background music with audio files with effects using Movie Maker.]

**Exercise No3: (2 Hours) – 1 Practicals**

Design a movie on given topic by using audio, video and photos with effects using windows movie maker. Following are to be followed to complete the given task.

Step 1: Create a New Collection
Step 2: Import Pictures
Step 3: Import Audio
Step 4: Drag your Media to the Storyboard
Step 5: Video Effects
Step 6: Video Transitions
Step 7: Titles or Credits
Step 8: Saving Your Movie

Step 1: Create a New Collection

- Click on the Collections Icon on the Toolbar.
- Right-click on the Collections folder and choose New Collection.

Type a descriptive name. All content for this project should be saved under this folder or subfolder in it. It is a good practice to create separate subfolders for photos, video, and audio.
Step 2: Import Pictures
- Click on the Collections Icon on the Toolbar.
- Click on the Collection in which you want to store your pictures (the folder you created in Step 1 or a subfolder)
- Click on File > Import into Collections
- In the Import File dialog box that appears, navigate to the folder that contains your pictures and select all of the pictures you want to import.
- Click Import.

OR
- Click on the Collection in which you want to store your pictures (the folder you created in Step 1 or a subfolder)
- Click on Tasks Icon on Toolbar to show Tasks Pane or View > Tasks Pane.
- Click on Import Pictures from the Movie Tasks Pane on the left.
  Navigate to the folder that contains your pictures and select all of the pictures you want to import.

Step 3: Import Audio
- Click on the Tasks Icon on the Toolbar.
- In the Taskpane, click on Import audio or music
  - Navigate to the music track you'd like to add to your movie.
  - Click on Import.
  - The music track will appear in your Collection view.
- Click on Show Timeline button in the Storyboard section of your screen.
- Drag your music track to the Audio/Music level of the Timeline.

Step 4: Drag your media to the Storyboard
- If you are not in Storyboard view, click Show Storyboard at the top left of the Timeline to return to Storyboard view.
  Click a clip in your Collection to select the clip.
- Hold down the mouse button and drag the clip to the first open frame on the Storyboard. Release the mouse button. You have now added a clip to the Storyboard.
- Note: You can insert a clip between two clips by selecting the clip in your collection and then dragging to the desired location.
Step 5: Video Effects

- Click on the **Tasks Icon** on the Toolbar.
- Click on **View Video Effects**.
- Select a Video Effect, click and drag the effect to the lower left-hand corner of the clip (designated by a Star).
- To delete the video effect, click on the star and press <delete>.

Step 6: Video Transitions

- Click on the **Tasks Icon** on the Toolbar.
- Click on **View Video Transitions**.
- Select a Video Transition, click and drag the effect to the empty box between the two clips.
- To delete the Video Transition, click on the box and press <delete>.
Step 7: Titles or Credits

- Click on the Tasks Icon on the Toolbar.
- Click Make Titles or Credits. You will get the window shown below.
- Select and click on which title you would like to add – Beginning, Before Clip, After Clip, End.
- When you are in the window to enter your text, make sure you check out the Title Animation and the Text Font and Color. In Text Font and Color you can change the text color, background color, size of text, font, transparency, and alignment.

Step 8a: Saving Your Movie if you are done with your Movie Project

- Click on the Tasks Icon on the Toolbar.
- Click on Save to My Computer or File > Save Movie File
- After your movie is saved, you can burn it to a CD with a CD burner, burn it to a DVD with a DVD burner, copy it to your memory stick (if your memory stick is large enough).
- Your movie will run with Windows Media Player software so anyone that has a PC running Windows should be able to view your movie on their computer.

Step 8b: Saving Your Project (not finished with your Movie Project yet)

File > Save Project

Note:

Your Project File is what you work on to get to your final movie product. It is in your Project File that you add the clips, add the effects, add transitions, insert titles, insert credits, and add audio. If you work on your project and you are not ready to make the movie yet, save your project with the following commands: File > Save Project. Once you save your project and you are happy with it, you can then save your movie file.
5. Lab Exercises:

(Purpose of this exercise is learn the tools and create the car advertisement in Photoshop just given as example below)

Exercise No 6: (2 Hours) - 1 Practicals

Step 1

First, we need to isolate the photo of Mercedes and put it on a white background to get the base of advertisement and a focal point to build around. The pen tool or magic wand will work best for this extraction.
Then we start to make the shadows with soft round brush. You can just paint below the extracted car layer on a new layer, based upon where you will place your light source.

**Step 2**

Invert the background layer using ctrl+i and make a new layer, with soft round brush paint some blue areas behind the car. Alternately you can create your own fill layer with a different color.

After that, we use a smoke brush and add a little mist on the left.
Step 3
To make it more realistic, I decided to add a clouds texture (http://www.shutterstock.com/pic.mhtml?id=24208522) on the background.

With the layer mask on, we erase the areas on the bottom right corner. Next, I took a green grass texture and desaturated it using hue/saturation (ctrl+u) or ctrl+shift+u.

Step 4
On the top of the layers we start to adding the trees (http://www.istockphoto.com /stockphoto-1204409-bonsai-tree.php?st=996a73c).
To blend the tree, use the curves to make it darker or brighter, and hue/saturation to make it desaturated or more colorful.
Paint the rest with a small brush, use the same colors like the tree and start to paint your wooden root.

Step 5
To show the rock use some photos of the stones and put it on the bottom of the project, also add one more wooden root on the left.
The same stones are put on the left background, which gives as an effect, like the car is staying on rocks.
6. Lab Exercises:
[Purpose of this exercise is to learn the tools and how to use different shapes to create an ornamental text effect in Photoshop]

Exercise No 6: (2 Hours) - 1 Practicals

Step 1: Document Creation/Background Creation
Open File->New to create a new document. Once your document is created we need to create a background, with a simple gradient. With colors set to light grey and white select the gradient tool and draw a gradient.

To enter the text, switch your type tool on (T on your keyboard) and set your text. The font and Text can be changed as shown below.

Now to hollow it out, select Layer->Layer Styles ->Stroke. Once you have done that set yours up as in the below screenshot.

Now once you have pressed ok change the FILL for your layer to 0% and leave the opacity at 100%. This should result in something like the below screenshot.
Now to make our shapes, make a new layer and fill it with blue.

Select pen tool using, P on keyboard and set it up as shown in the below screenshot.

Now just make a random loopy shape. Something like a distorted bean should work fine.

Once your shape is finished and closed (all the lines connect) right click and select make selection and then just press ok when the dialog box comes up.
Now we have a selection of our shape that we can cut and paste back into the document.

To dodge the blue shape and burn it, to change the flat 2D shape into a 3D shape. Start off by pressing O on your keyboard and set your dodge tool up as shown in the below screenshot, then just right click and set your brush up like as in the below screenshot. Choose your brush size according to the working
document size (e.g. if your working on a document smaller like 1200*800 you will need to obviously use a smaller brush)

Now just go along one of the sides with your brush, you see that it goes from dark blue to a light shade of cyan, this in turn becomes the side that’s in the light.

Now we can switch over to our burn tool, with the same brush and repeat this process on the opposite side.
Now despite the fact that there is no direct light source in our document you should still go with the basic idea of how this works. Take for instance the below screenshot, light comes from one side and hits the shape, this being our cyan side, the opposing side is darker because the light is not shining on it, this in turn is the burnt side.

For now you could say our shape is complete and ready to be incorporated into the text. We can use the same shape with converting it into different shape and rotating it into different directions. To do this start off by rotating your shape 90 degrees then apply a twirl filter like shown below. This should turn your shape into something like the below screenshot.

Like this I will create the different shapes and kept all of them (un-3D’d) on a single layer, they look like the below screenshot.

So change the color of these shapes from blue to the hue with our hue and saturation editor.
This makes our shape look like the below screenshot. And as you can see, its still 3D.

Step3: Text placement

Now we have our text made, hollowed out and have different shapes. Now we have to fill it with different shapes and colors objects.

So let’s start off with I in “I m” by placing a shape in the bottom section of it. The shape inside the I is outline.

Continue building upwards/downwards, do not start in the middle. Continue on with the rest of your letters, which looks like the below

7 Lab Exercises:
Exercise No 7: (2 Hours) - 1 Practicals

1. Take Two Images one of Sunflower and another of butterfly.
2. Open two images with the Photoshop as two separate documents.
3. Check the Image resolution by using View->Image size. If the resolution is less set it to 172 or any resolution as per your choice according to clarity and size.
4. To add the butterfly effect to the flower, increase the canvas size in upward direction of the picture by using Image Size. 
5. Use the Stamp tool to create the same background effect of flower bys using Alt+ Stamp tool.
6. Go to Butterfly Image file. Select the Magnetic loso tool and select the boundaries of the butterfly to be merged on Sunflower.
7. After selection using right mouse click select the Copy Via Layer option which will show the selected Image on a separate layer.
8. Drag the separate layer of butterfly to the sunflower document and impose it on it.
9. To merge and combine the two images use Layer> Flatten Image.
10. Save the image.

8. Lab Exercises:

Virtual DJ is audio mixing software that allows you to mix and blend digital music files with virtual turntable software. This software has enhanced capability that can enable you to mix, master, chop, screw and blend the music of your choice. With this digital feature, you can make any song sound exactly how you’d prefer it to sound.

Exercise No 8: (2 Hours) - 1 Practicals

Mixing songs can be useful to disk jockeys that use special mixes at the events they DJ or for someone who wishes to create special mixes of his favorite songs. Mixing songs together is an art form in itself. While what sounds good is largely a matter of taste, there are a few ways to help ensure the sound quality of a mixed musical track.

1. Choose the songs you want to mix together. Use good judgment. Just about any songs can be mixed and made to go together well, but songs with extremely different tempos may be harder to combine into a smooth mix. That's
not to say you can combine only tracks of the same tempo. You should just be aware of extreme differences.

2. Open the first song you want in your mix using the audio editing software of your choice. There are many programs on the market capable of mixing tracks, including several free audio software packages (see Resources). These programs read and write files to the popular audio formats and include tools for slicing and adding sound effects to your music.

3. Mark the portion of the first music track you want to include in your mix. This is done by moving slider bars to mark the beginning and end of the portion you want to cut from the song. Once you've marked your portion, cut it from the original track and save it with a new file name to avoid overwriting your original track. It's a good idea to save this first cut with the name of the track you're mixing.

4. Open another song and cut the portion you want to add to the first file you created. Save the file with the same file name and a number. Open the first track you created and use the splicing tools on the "Edit" menu to combine the tracks in whatever order you wish. Apply a transitional effect between the two, such as fade or wipe, to create a transition that doesn't disrupt the rhythm of the song.

5. Apply additional effects like reverb to enhance the song, but be careful not to overdo it. Audio editing software includes a number of sound effects and enhancement features that can ruin a song when they are overused. Before you burn the finished track, adjust the overall volume of the track as well as bass and treble settings.

**BROADCASTING AND RECORDING**

VirtualDJ provides an additional ability to record or broadcast the output. To access the recording and broadcasting features click on the —Record tab. The following interface is displayed.

The following methods are available:

- Record Audio
- Burn CD
- Broadcast
- Record Movie

To access the recording settings click on the —Config button at the top center of the interface.
By default, VirtualDJ uses the internal Master output of VirtualDJ's internal mixer capabilities to record or broadcast. To use an alternative line input – please see the Audio Setup guide for directions on how to use the Record Loopback option in Advanced Config.

**Record Audio**
—Record Audio|| provides recording a mix session to a .WAV or .MP3 file direct to the system’s hard drive. When the recording is completed, it can then be listened to in VirtualDJ, edited with an audio editing application, or written to a CD using a CD burning software.
To setup the —Record Audio||, click on —Config to access the configuration settings for recording a file.

**Record From** –

**Auto-Start** – checking this box will automatically begin the recording when the first track begins playing. If not checked then manual activation of the recording will need to be activated using the —Start Recording|| button

**File** –

**Path** – provide the path and name of the file where the recording is going to be saved.

**Prompt if overwrite** – checked will prompt to overwrite when trying to record to a file that already exists.

**Split in multiple files** – checked will split the session as separate tracks, instead of one large audio file. When splitting to separate tracks, a —Cut|| button appears next to the —Start Recording|| button to demarcate tracks. The —Auto-split on crossfade|| option will automatically demarcate tracks when the crossfader in the VirtualDJ interface begins to move to the deck being mixed in.

**Format** – select the audio file format to be used when recording.

**WAV** – will record a .WAV audio file

**MP3** – will record an .MP3 audio file

**Encoder** – this is the path to the MP3 encoder for use in recording the MP3. If the encoder to use is in a different folder than the VirtualDJ folder, use the browse button to navigate and select the encoder’s location

**Bitrate** – select the bitrate to use in recording the MP3. A bitrate of 192Kbps is recommended for CD-quality recording. Once the choices are set, click —OK and then —Start Recording when ready. Press —Stop Recording when finished with the session.

**Burn CD**
VirtualDJ can record the session in a CD image format for quick burning of a session to CD.
Select —"Burn CD" for VirtualDJ to record the session as a .BIN/.CUE file type which contains all the necessary information for burning software that supports image types of BIN and CUE.

Click on —"Config" to access the configuration settings for CD recording.

**Record From**

**Auto-Start** – checking this box will automatically begin the recording when the first track begins playing. If not checked then manual activation of the recording will need to be activated using the —Start Recording|| button

**File**

**Path** – provide the path and name of the file where the recording is going to be saved.

**Prompt if overwrite** – checked will prompt to overwrite when trying to record to a file that already exists.

Once the choices are set, click —OK and then —Start Recording when ready. Press —Stop Recording when finished with the session. And, to demarcate tracks use the — Cut button found next to the —Start Recording button. When finished recording the .BIN/.CUE file specified in the File Path field can be burned with a .BIN/.CUE supported CD-burning application. For more information about burning .BIN/.CUE files, consult the documentation of provided by the CD burning software. 61

**Broadcasting to Internet ("Broadcast") with BROADCASTER, PRO BASIC /PRO FULL Platform**

VirtualDJ provides a method for broadcasting the session in real time on the Internet as a —webcast||. This way people around the world can listen to the mix session.

Click on —Config to access the configuration settings for recording a file.

**Record From**

- **Auto-Start** – checking this box will automatically begin the recording when the first track begins playing. If not checked then manual activation of the recording will need to be activated using the —Start Recording|| button

**Format**

- Icecast – OGG format streaming
- Shoutcast – MP3 format streaming Shoutcast will also need to know which MP3 Encoder will be used.
- Encoder – Use the browse button ( ... ) to navigate the computer folder structure and select the encoder file to use.
- Bitrate - Select the desired bitrate for the encoding. **NOTE:** Higher bitrates will consume a large bandwidth in the internet connection to stream and listen to MP3 audio.

**9. Lab Exercises:**

(Purpose of these exercises is to use Virtual DJ for video mixing of two different videos and give them video effects.)
Exercise No 9: (2 Hours) - 1 Practicals
Learn how to mix video in Virtual DJ and more about playing and mixing electronic music in this free instructional video.

In addition to mixing traditional audio, VirtualDJ makes it possible to mix video content with the ease and familiarity of a DJ interface. Instead of audio files (.mp3, .wma, .m4a, etc.), video files (.avi, .mpg, .wmv, .vob, etc.) can be played. VirtualDJ’s interface provides all the same features to mix, scratch, effect, and transition video content, just as with audio content. Additionally, you can link video files to audio files to produce a video enhanced combination. Using the drag-n-drop preview windows, keyboard shortcut action, or a skin provided link object any type of supported video file can be linked to an audio track.

Video Interface

By selecting the Video button on the center-top of the mixer zone, the internal mixer controls are replaced by several video options.

Three video viewing windows are displayed – Master Out, Left Deck (A), and Right Deck (B). With these windows you are able to see the video feeds of the 2 decks and what your resulting output will be to your video devices.

Below Left Deck is the Transitions selection button. Clicking on the down arrow will provide a list of installed transitions to choose from. By clicking on the transition title will activate that transition and immediately cross fade to the opposing deck.

For automatic mixing from the currently playing deck to the next deck coming in when you press Play, activate the Auto option to the left of the video cross fader. Now your transitions will begin once you begin to play the track on the opposite deck. This option can also be set in the Video configuration tab.

Clicking on the preview windows for Left Deck and Right Deck will activate the transition to move from one deck to the other.

You can manually cross fade the transition by moving the video fader from one deck to the other.

And, if the Link to the right of the video cross fader or -Link the Video crossfader- in the Video configuration tab is checked, the skin's audio crossfader will crossfade the video when it is move from one deck to the other.

Just like the audio effects the Transition Effects can be selected and activated from the effects panel area. Just select the -Video Transitions- section, then select the desired transition and activate it.

Video Effects

Similarly to audio effects, video effects are used to transform the video on either deck. Use the -"Video Effects" in the -"Effects" panel and activate the desired effect on the specific deck. Or, select and activate the video effect from the control underneath the Right Deck preview video window. Select the desired effect using the down arrow on the control and then click on the displayed name to activate it.
**Video Files in the Browser**

Video files are distinguished in the Browser with a small, blue —"V" on their icon. And, audio files with linked videos are distinguished in the Browser with a small, blue —"L" on their icon. When playing a video/linked audio file, a video window will open in VirtualDJ.

**Optimization**

In general, video mixing is much heavier in computer resources than audio mixing so certain optimization may help performance, especially when dealing with full frame rate video (such as DVD in high definition). There are several parameters which determine the speed with which VirtualDJ decompresses and displays video content – the size of memory present on your video card, the speed of the graphics processor (GPU), the speed of the main central processor (CPU), and the access speed of the hard disk.

Another parameter which largely influences performance is the type of file. An MPEG1 format file is much faster to decompress than a VOB format file. In a similar way, a file with a 320x240 resolution is much faster to decompress than a file with a 720x576 resolution. By default, VirtualDJ decompresses only the content which is visible in the video mix window. This means that if there are two clips which are playing but only one is visible, VirtualDJ will only decompress the video which is visible. If both video files are shown in the mix window, then VirtualDJ will decompress both. This makes the software perform quicker and also allows it to perform better on slower machines. However, this may result in small jolts at the time of transitions. If the computer configuration is sufficiently powerful, we recommend checking the —Decode while hidden[] box in the —Video[] settings in the —"Config" menu to obtain more fluid transitions.

And finally, we recommend the use of an output resolution no greater than the resolution of the video files. If using higher resolutions, low-resolution content will not look any better but will be using more computer resources. A resolution of 800x600 should be sufficient if using high-quality DVD video.

**RECORD MOVIE**

**Record Movie**

Click on —Config to access the configuration settings for video recording.

**Record From** –
- **Auto-Start** – checking this box will automatically begin the recording when the first track begins playing. If not checked then manual activation of the recording will need to be activated using the —Start Recording[] button

**File** –
**Path** – provide the path and name of the file where the recording is going to be saved.
**Prompt if overwrite** – checked will prompt to overwrite when trying to record to a file that already exists.
**Format** –
Select the appropriate codec available on your system to record the video stream with.

Once the choices are set, click —OK‖ and then —Start Recording‖ when ready. Press —Stop Recording‖ when finished with the session. When finished recording the file specified in the File Path field can now be burned to a CD/DVD or immediately used as a track in VirtualDJ.

10. Lab Exercises:
[Purpose of these exercises is to use Cool Edit Pro to Open and edit use multiple tracks and for mixing and editing of different audios]

Exercise No 10: ( 2 Hours) - 1 Practicals

Open
1. First make sure your in the Multi track mode. Then go to the File menu, Open, from the list choose ‘Windows PCM (*wav).

2. Open the following files, “beat.wav”, “drum.wav”, “moo0.wav”, and “waves.wav”. As you will see none of the wave files are displayed. This is because they have opened up in the single track mode.

3. To now Import the movies into multi track go the track and right click on it. The context menu should appear.

4. In the context menu, go to “Insert”, then from the drop down list choose “waves.wav”. The sound will open in the first track starting in the position your sound file was at.

5. Go down to track 2. Right click again and choose “beat.wav”.

6. Track 3 choose “drum.wav”
7. Track 4 is “moo0.wav”

Moving
We will now move the tracks around to align them to play at certain places.
1. Left click on “waves.wav” in track 1. This will select it.

2. Right click on the sound and drag to the left. As you can see the sound file moves along the timeline.

3. Flush it at the beginning.

4. Depending if snapping is on move track 2, “beat.wav” to just after the initial rise of the wave’s sound file (about 5 seconds in).

5. Move track 3, “drum.wav”, so that it begins right after track 2 ends (again if snapping is enabled).

6. For now move track 4 “mo0.wav” out of the way (IE to the right) for now.

Loop Duplication
To create the rhythm for this work, we will loop/repeat some of the sounds.
1. Left click on “beat.wav” in track 2. Then right click on it. From the context menu choose “Loop Duplicate”. 
2. In the dialogue box tell it to repeat 10 times without any gaps. Hit “OK” then. The track will repeat itself 10 times.

3. Double left click on track 2. This will take you to single track mode. Notice that the length of the track is 2.192.

4. Go back to multi track mode by clicking the switch button in the upper left corner.

5. Back in Multi Track left click on track 3 “drum.wav”. Again choose loop duplicate. This time however check “Evenly Spaced”, and enter 2.192. Click “OK”.

6. On track 3, the last repeat of the sound file “drum.wav” is not needed. Go and click on this instance and hit “Delete” on your keyboard.

7. Go to the third instance of “drum.wav” again choose loop duplicate upon right clicking on it and repeat 10 times, but the gaps this time put “1.096”. Hit “OK”.

---

We will now complete editing the wave file.

1. In track 4 move “moo0.wav” over to it aligns
in the middle of the tracks you have created.

2. Click on the last instance of track 2 beat. Depending on the tools available open through the View menu, you should have a green line going across the top of the track. Left click on this bar and drag down until the right. This is the volume bar, and will fade-out the last instance of this sound.

**Mix Down Savings**

The final step is to mix down the file and then save it.
1. Go to the Edit menu, then choose “Mix Down”, and then “All Waves”.

**Mix Down Menu**

2. A new Single track will be created that is all the waves from the multi track saved in one stereo file. Click on the File menu, and “Save As”. Choose windows pcm for the file format, then “final.wav” as the file name.

![Mix Down Menu](image)

Final Mixed File
5. Conduction of Viva-Voce Examinations:

Teacher should oral exams of the students with full preparation. Normally, the objective questions with guess are to be avoided. To make it meaningful, the questions should be such that depth of the students in the subject is tested Oral examinations are to be conducted in co-cordial environment amongst the teachers taking the examination. Teachers taking such examinations should not have ill thoughts about each other and courtesies should be offered to each other in case of difference of opinion, which should be critically suppressed in front of the students.
6. Submission:

Document Standard:
A] Page Size A4 Size
B] Running text Justified text
C] Spacing 1 Line
D] Page Layout and Margins (Dimensions in Cms)

<table>
<thead>
<tr>
<th>Description</th>
<th>Font</th>
<th>Size</th>
<th>Boldness</th>
<th>Italic</th>
<th>Underline</th>
<th>Capitalize</th>
</tr>
</thead>
<tbody>
<tr>
<td>College Name</td>
<td>Arial</td>
<td>24</td>
<td>--------</td>
<td>------</td>
<td>Yes</td>
<td>-----------</td>
</tr>
<tr>
<td>Document Title</td>
<td>Tahoma</td>
<td>22</td>
<td>--------</td>
<td>------</td>
<td>----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Document Subject</td>
<td>Century Gothic</td>
<td>14</td>
<td>--------</td>
<td>------</td>
<td>----------</td>
<td>Capital</td>
</tr>
<tr>
<td>Class</td>
<td>Bookman old Style</td>
<td>12</td>
<td>--------</td>
<td>------</td>
<td>----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Document No</td>
<td>Bookman old Style</td>
<td>10</td>
<td>--------</td>
<td>------</td>
<td>----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Copy write inf</td>
<td>Bookman old Style</td>
<td>9</td>
<td>--------</td>
<td>------</td>
<td>----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Forward heading</td>
<td>Bookman old Style</td>
<td>12</td>
<td>--------</td>
<td>------</td>
<td>Yes</td>
<td>Capital</td>
</tr>
<tr>
<td>Forward matter</td>
<td>Bookman old Style</td>
<td>12</td>
<td>--------</td>
<td>------</td>
<td>----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Lab man Contents title</td>
<td>Bookman old Style</td>
<td>12</td>
<td>--------</td>
<td>------</td>
<td>Yes</td>
<td>Capital</td>
</tr>
<tr>
<td>Index title</td>
<td>Bookman old Style</td>
<td>12</td>
<td>Yes</td>
<td>------</td>
<td>Yes</td>
<td>Capital</td>
</tr>
<tr>
<td>Index contents</td>
<td>Bookman old Style</td>
<td>12</td>
<td>--------</td>
<td>------</td>
<td>----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Heading</td>
<td>Tahoma</td>
<td>14</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-----------</td>
</tr>
<tr>
<td>Running Matter</td>
<td>Comic Sans MS</td>
<td>10</td>
<td>--------</td>
<td>------</td>
<td>----------</td>
<td>-----------</td>
</tr>
</tbody>
</table>

Horizontal
7. Evaluation and marking system:

Basic honesty in the evaluation and marking system is absolutely essential and in the process impartial nature of the evaluator is required in the examination system to become popular amongst the students. It is a wrong approach or concept to award the students by way of easy marking to get cheap popularity among the students to which they do not deserve. It is a primary responsibility of the teacher that right students who are really putting up lot of hard work with right kind of intelligence are correctly awarded.

The marking patterns should be justifiable to the students without any ambiguity and teacher should see that students are faced with unjust circumstances.